Amazon (AWS) global internet outage
Incident Report for
Weever Apps
Resolved
All indications are that the global AWS outage is now resolved and our services are back to normal operations.
Posted
Oct
20
,
2025
-
19:02
EDT
Update
We are seeing ongoing issues with Weever Process due to the global AWS outage. We are monitoring the situation. AWS is working to fix the issue.
Posted
Oct
20
,
2025
-
13:26
EDT
Monitoring
OKTA and AWS system issues have largely been resolved. We are monitoring for any new or intermittent issues as the systems stabilize.
Posted
Oct
20
,
2025
-
11:04
EDT
Identified
The issue has been identified.
Posted
Oct
20
,
2025
-
09:06
EDT
Monitoring
Added link to BBC news article.
Posted
Oct
20
,
2025
-
09:06
EDT
Update
We are waiting for AWS system restoration.
Posted
Oct
20
,
2025
-
09:05
EDT
Identified
We are aware of an issue with Amazon web hosting (AWS) which is blocking OKTA single sign on (login) for some of our customers. Weever is awaiting restoration of service. More information is available here:
https://www.bbc.com/news/live/c5y8k7k6v1rt
and
https://status.okta.com/#incident/a9CKZ000000oMAo2AM
Posted
Oct
20
,
2025
-
09:03
EDT
This incident affected: Products (Process Manager, Inspections Manager, Forms Manager) and Integrations (OKTA single sign on (login)).
×
Subscribe to Incident
Subscribe to updates for
Amazon (AWS) global internet outage
via . You'll receive .